Back to overview
Degraded

Investigating Latency in Backend Services

Apr 20, 2026 at 3:30pm UTC
Affected services
LOS
PPE
Agent Portal

Resolved
Apr 20, 2026 at 6:40pm UTC

Update: The infrastructure issue affecting our scale-up algorithms was resolved at approximately 11:00 AM. Following the fix, we monitored the system closely, and all services achieved full stability by 11:40 AM.

Our team is currently working with our infrastructure provider to conduct a thorough root cause analysis to prevent this from recurring. We thank you for your continued patience and support while we worked to resolve this.

Created
Apr 20, 2026 at 3:30pm UTC

We are currently investigating an infrastructure related issue affecting our backend services, which began at approximately 7:30 AM PT. The disruption is tied to our auto-scaling algorithms, and our engineering team is currently working with our infrastructure provider to stabilize the environment. We apologize for the impact and will provide further updates as we learn more.